High throughput due to new pope election

Incident Report for Poool

Resolved

Request throughput is back to normal. We will continue to monitor response times for the next hours.
Posted May 08, 2025 - 21:41 CEST

Identified

We are currently experiencing very high & unusual throughput due to the ongoing pope election. We implemented a fix to sustain the load and are monitoring the results.
Posted May 08, 2025 - 18:47 CEST
This incident affected: Infrastructure and Engage SDK.